copyDatabase Method

Create a copy of an existing database within this CloudContainer with a new name.

copyDatabase(dbName: string, toAlias: string): Promise<void>

note CloudSqlite uses copy-on-write semantics for this operation. That is, this method merely makes a new entry in the manifest with the new name that shares all of its blocks with the original database. If either database subsequently changes, the only modified blocks are not shared.

Parameter Type Description
dbName string  
toAlias string  

Returns - Promise<void>

Last Updated: 20 June, 2023