cleanDeletedBlocks Method

Clean any unused deleted blocks from cloud storage. When a database is written, a subset of its blocks are replaced by new versions, sometimes leaving the originals unused. In this case, they are not deleted immediately. Instead, they are scheduled for deletion at some later time. Calling this method deletes all blocks in the cloud container for which the scheduled deletion time has passed.

cleanDeletedBlocks(nSeconds?: number): Promise<void>

Parameter Type Description
nSeconds number Any block that was marked as unused before this number of seconds ago will be deleted. Specifying a non-zero
value gives a period of time for other clients to refresh their manifests and stop using the now-garbage blocks. Otherwise they may get
a 404 error. Default is 1 hour.

Returns - Promise<void>

Last Updated: 20 June, 2023