BisCoreSchema Class
The BisCore schema is the lowest level Schema in an iModel.
It is automatically registered when IModelHost.startup is called.
** Example:**
// Make sure somewhere in your startup code you call: IModelHost.startup()
// Get the JavaScript class for the "Element" BIS Class
const elementClass = ClassRegistry.findRegisteredClass("BisCore:Element")!;
assert.equal("BisCore", elementClass.schema.schemaName);
assert.equal("Element", elementClass.className);
Extends
Inherited methods
Name | Inherited from | Description |
---|---|---|
toSemverString(paddedVersion: string): string Static | Schema | Get a semver-compatible string from a padded version string. |
Properties
Name | Type | Description | |
---|---|---|---|
schemaFilePath Accessor StaticReadOnly | string | ||
schemaName Accessor StaticReadOnly | string |
Defined in
- backend/src/BisCoreSchema.ts Line 35
Last Updated: 20 June, 2023