handle MethodStatic
Establish a handler for an Ipc channel to receive Frontend.invoke calls
handle(channel: string, handler: (...args: any[]) => Promise<any>): RemoveFunction
note returns A function to call to remove the handler.
Parameter | Type | Description |
---|---|---|
channel | string | The name of the channel for this handler. |
handler | (...args: any[]) => Promise<any> | A function that supplies the implementation for channel |
Returns - RemoveFunction
Defined in
- backend/src/IpcHost.ts Line 66
Last Updated: 20 June, 2023