restartSession Method
Restart the current TxnManager session. This causes all Txns in the current session to no longer be undoable (as if the file was closed and reopened.)
restartSession(): void
note This can be quite disconcerting to the user expecting to be able to undo previously made changes. It should only be used under extreme circumstances where damage to the file or session could happen if the currently committed are reversed. Use sparingly and with care. Probably a good idea to alert the user it happened.
Returns - void
Defined in
- backend/src/TxnManager.ts Line 350
Last Updated: 20 June, 2023