createFrom MethodStatic
Create a local Snapshot iModel file, using this iModel as a seed or starting point. Snapshots are not synchronized with iModelHub, so do not have a change timeline.
Note: A snapshot cannot be modified after SnapshotDb.close is called.
createFrom(iModelDb: IModelDb, snapshotFile: string, options?: CreateSnapshotIModelProps): SnapshotDb
see Snapshot iModels
Parameter | Type | Description |
---|---|---|
iModelDb | IModelDb | The snapshot will be initialized from the current contents of this iModelDb |
snapshotFile | string | The file that will contain the new iModel snapshot |
options | CreateSnapshotIModelProps | Optional properties that determine how the snapshot iModel is created. |
Returns - SnapshotDb
A writeable SnapshotDb
Defined in
- backend/src/IModelDb.ts Line 2588
Last Updated: 20 June, 2023