createEmpty MethodStatic
Create an empty local Snapshot iModel file. Snapshots are not synchronized with iModelHub, so do not have a change timeline.
Note: A snapshot cannot be modified after SnapshotDb.close is called.
createEmpty(filePath: string, options: CreateEmptySnapshotIModelProps): SnapshotDb
see Snapshot iModels
Parameter | Type | Description |
---|---|---|
filePath | string | The file that will contain the new iModel snapshot |
options | CreateEmptySnapshotIModelProps | The parameters that define the new iModel snapshot |
Returns - SnapshotDb
A writeable SnapshotDb
Defined in
- backend/src/IModelDb.ts Line 2568
Last Updated: 20 June, 2023