PushChangesArgs Interface
Parameters for pushing changesets to iModelHub
Extends
Properties
Name | Type | Description | |
---|---|---|---|
description | string | A description of the changes. | |
mergeRetryCount | undefined | number | number of times to retry pull/merge if other users are pushing at the same time. | |
mergeRetryDelay | undefined | BeDuration | delay to wait between pull/merge retry attempts. | |
pushRetryCount | undefined | number | the number of time to attempt to retry to push the changeset upon failure. | |
pushRetryDelay | undefined | BeDuration | The delay to wait between retry attempts on failed pushes. | |
retainLocks | undefined | "true" | if present, the locks are retained after the operation. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
accessToken Readonly | undefined | string | TokenArg | If present, the access token for the requested operation. |
Defined in
- backend/src/BriefcaseManager.ts Line 43
Last Updated: 20 June, 2023