saveSettingDictionary Method
Beta
Save a SettingDictionary
in this iModel that will be loaded into workspace.settings every time this iModel is opened in future sessions.
saveSettingDictionary(name: string, dict: SettingObject): void
note All saved SettingDictionary
s are loaded into workspace.settings every time an iModel is opened.
Parameter | Type | Description |
---|---|---|
name | string | The name for the SettingDictionary. If a dictionary by that name already exists in the iModel, its value is replaced. |
dict | SettingObject | The SettingDictionary object to stringify and save. |
Returns - void
Defined in
- backend/src/IModelDb.ts Line 1288
Last Updated: 20 June, 2023