queryViewDefinitionProps Method
Query for the array of ViewDefinitionProps of the specified class and matching the specified IsPrivate setting.
queryViewDefinitionProps(className: string = "BisCore.ViewDefinition", limit: number = IModelDb.defaultLimit, offset: number = 0, wantPrivate: boolean = false): ViewDefinitionProps[]
Parameter | Type | Description |
---|---|---|
className | string | Query for view definitions of this class. |
limit | number | |
offset | number | |
wantPrivate | boolean | If true, include private view definitions. |
Returns - ViewDefinitionProps[]
Defined in
- backend/src/IModelDb.ts Line 2020
Last Updated: 20 June, 2023