forEachMetaData MethodStatic
Invoke a callback on each property of the specified class, optionally including superclass properties.
forEachMetaData(iModel: IModelDb, classFullName: string, wantSuper: boolean, func: PropertyCallback, includeCustom: boolean = true): void
note Custom-handled properties are core properties that have behavior enforced by C++ handlers.
Parameter | Type | Description |
---|---|---|
iModel | IModelDb | The IModel that contains the schema |
classFullName | string | The full class name to load the metadata, if necessary |
wantSuper | boolean | If true, superclass properties will also be processed |
func | PropertyCallback | The callback to be invoked on each property |
includeCustom | boolean | If true (default), include custom-handled properties in the iteration. Otherwise, skip custom-handled properties. |
Returns - void
Defined in
- backend/src/IModelDb.ts Line 1042
Last Updated: 20 June, 2023