addNewFont Method
Beta
Add a new font name/type to the FontMap for this iModel and return its FontId.
addNewFont(name: string, type?: FontType): number
Parameter | Type | Description |
---|---|---|
name | string | The name of the font to add |
type | FontType | The type of the font. Default is TrueType. |
Returns - number
The FontId for the newly added font. If a font by that name/type already exists, this method does not fail, it returns the existing Id.
Defined in
- backend/src/IModelDb.ts Line 298
Last Updated: 20 June, 2023