ExportGraphicsInfo Interface
Info provided to ExportGraphicsFunction about graphics. See IModelDb.exportGraphics
Properties
Name | Type | Description | |
---|---|---|---|
color | number | The color and transparency for these graphics | |
elementId | string | The element ID for the element the graphics originated from | |
geometryClass | GeometryClass | GeometryClass for these graphics | |
materialId | undefined | string | If defined, ID for the RenderMaterialElement for these graphics | |
mesh | ExportGraphicsMesh | The mesh for these graphics | |
subCategory | string | ID for the SubCategory for these graphics | |
textureId | undefined | string | If defined, ID for the Texture for these graphics |
Defined in
- backend/src/ExportGraphics.ts Line 69
Last Updated: 20 June, 2023