CheckpointProps Interface
Properties of a checkpoint
Extends
Properties
Name | Type | Description | |
---|---|---|---|
allowPreceding Readonly | undefined | boolean | If true, then the latest successful v2 checkpoint at or before the provided changeset will be returned when calling queryV2Checkpoint. | |
changeset Readonly | ChangesetIdWithIndex | changeset for the checkpoint | |
expectV2 Readonly | undefined | boolean | ||
iModelId Readonly | string | Id of the iModel | |
iTwinId Readonly | string | iTwin that the iModel belongs to | |
reattachSafetySeconds Readonly | undefined | number | The number of seconds before the current token expires to attempt to reacquire a new token. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
accessToken Readonly | undefined | string | TokenArg | If present, the access token for the requested operation. |
Defined in
- backend/src/CheckpointManager.ts Line 31
Last Updated: 20 June, 2023