deleteBriefcaseFiles MethodStatic
Delete and clean up a briefcase and all of its associated files. First, this method opens the supplied filename to determine its briefcaseId. Then, if a requestContext is supplied, it releases a BriefcaseId from iModelHub. Finally it deletes the local briefcase file and associated files (that is, all files in the same directory that start with the briefcase name).
deleteBriefcaseFiles(filePath: string, accessToken?: string): Promise<void>
Parameter | Type | Description |
---|---|---|
filePath | string | the full file name of the Briefcase to delete |
accessToken | string | for releasing the briefcaseId |
Returns - Promise<void>
Defined in
- backend/src/BriefcaseManager.ts Line 279
Last Updated: 20 June, 2023