createCode MethodStatic
Create a Code for a RenderMaterial given a name that is meant to be unique within the scope of the specified DefinitionModel.
createCode(iModel: IModelDb, scopeModelId: string, name: string): Code
Parameter | Type | Description |
---|---|---|
iModel | IModelDb | The IModelDb |
scopeModelId | string | The Id of the DefinitionModel that contains the RenderMaterial and provides the scope for its name. |
name | string | The RenderMaterial name |
Returns - Code
Defined in
- backend/src/Material.ts Line 81
Last Updated: 20 June, 2023