createCode MethodStatic
Create a Code for a PhysicalMaterial given a name that is meant to be unique within the scope of the specified DefinitionModel.
createCode(iModel: IModelDb, definitionModelId: string, name: string): Code
Parameter | Type | Description |
---|---|---|
iModel | IModelDb | The IModelDb |
definitionModelId | string | The Id of the DefinitionModel that will contain the PhysicalMaterial and provide the scope for its name. |
name | string | The name (codeValue) of the PhysicalMaterial |
Returns - Code
Defined in
- backend/src/Material.ts Line 30
Last Updated: 20 June, 2023