createCode MethodStatic
Create a Code for a LineStyle definition given a name that is meant to be unique within the scope of the specified model.
createCode(iModel: IModelDb, scopeModelId: string, codeValue: string): Code
Parameter | Type | Description |
---|---|---|
iModel | IModelDb | The IModel |
scopeModelId | string | The Id of the DefinitionModel that contains the LineStyle and provides the scope for its name. |
codeValue | string | The name of the LineStyle |
Returns - Code
A LineStyle Code
Defined in
- backend/src/Element.ts Line 1580
Last Updated: 20 June, 2023