onChildDelete MethodProtectedStatic
Beta
Called when an element with an instance of this class as its parent is about to be deleted.
onChildDelete(_arg: OnChildElementIdArg): void
note throw an exception if the element should not be deleted
note implementers should not presume that the element was deleted if this method does not throw, since the delete may fail for other reasons. Instead, rely on Element.onChildDeleted for that purpose.
note this
is the class of the parent Element whose child will be deleted
Parameter | Type | Description |
---|---|---|
_arg | OnChildElementIdArg |
Returns - void
Defined in
- backend/src/Element.ts Line 204
Last Updated: 20 June, 2023