onBeforeOutputsHandled MethodProtectedStatic
Beta
Called when a root element in a subgraph is changed and before its outputs are processed. This special callback is made when:
- the element is part of an ElementDrivesElement graph, and
- the element has no inputs, and
- none of the element's outputs have been processed.
onBeforeOutputsHandled(_id: string, _iModel: IModelDb): void
see ElementDrivesElement for more on element dependency graphs.
Parameter | Type | Description |
---|---|---|
_id | string | |
_iModel | IModelDb |
Returns - void
Defined in
- backend/src/Element.ts Line 309
Last Updated: 20 June, 2023