onAllInputsHandled MethodProtectedStatic
Beta
Called on an element in a graph after all of its inputs have been processed and before its outputs are processed. This callback is made when:
- the specified element is part of an ElementDrivesElement graph, and
- there was a direct change to some element upstream in the dependency graph.
- all upstream elements in the graph have been processed.
- none of the downstream elements have been processed. This method is not called if none of the element's inputs were changed.
onAllInputsHandled(_id: string, _iModel: IModelDb): void
see ElementDrivesElement for more on element dependency graphs.
Parameter | Type | Description |
---|---|---|
_id | string | |
_iModel | IModelDb |
Returns - void
Defined in
- backend/src/Element.ts Line 321
Last Updated: 20 June, 2023