insert Method
Insert this Element into the iModel.
insert(): string
see IModelDb.Elements.insertElement
note For convenience, the value of this.id
is updated to reflect the resultant element's id.
However when this.federationGuid
is not present or undefined, a new Guid will be generated and stored on the resultant element. But
the value of this.federationGuid
is not updated. Generally, it is best to re-read the element after inserting (e.g. via IModelDb.Elements.getElement)
if you intend to continue working with it. That will ensure its values reflect the persistent state.
Returns - string
Defined in
- backend/src/Element.ts Line 440
Last Updated: 20 June, 2023