getPredecessorIds Method
Beta
Deprecated in 3.x. use Element.getReferenceIds instead, the use of the term predecessors was confusing and became inaccurate when the transformer could handle cycles
Get the Ids of this element's references. A reference is any element whose id is stored in the EC data of this element This is important for cloning operations but can be useful in other situations as well.
getPredecessorIds(): Id64Set
Returns - Id64Set
Defined in
- backend/src/Element.ts Line 369
Last Updated: 20 June, 2023