collectPredecessorIds MethodProtected
Deprecated in 3.x. use Element.collectReferenceIds instead, the use of the term predecessors was confusing and became inaccurate when the transformer could handle cycles
Beta
Collect the Ids of this element's references at this level of the class hierarchy.
collectPredecessorIds(predecessorIds: Id64Set): void
Parameter | Type | Description |
---|---|---|
predecessorIds | Id64Set |
Returns - void
Defined in
- backend/src/Element.ts Line 350
Last Updated: 20 June, 2023