findAllBySource MethodStatic
Look up the elements that contain one or more ExternalSourceAspect with the specified Scope, Kind, and Identifier. The result of this function is an array of all of the ExternalSourceAspects that were found, each associated with the owning element. A given element could have more than one ExternalSourceAspect with the given scope, kind, and identifier. Also, many elements could have ExternalSourceAspect with the same scope, kind, and identifier. Therefore, the result array could have more than one entry with the same elementId. Aspects are never shared. Each aspect has its own unique ECInstanceId.
findAllBySource(iModelDb: IModelDb, scope: string, kind: string, identifier: string): { aspectId: string, elementId: string }[]
Parameter | Type | Description |
---|---|---|
iModelDb | IModelDb | The iModel to query |
scope | string | The scope of the ExternalSourceAspects to find |
kind | string | The kind of the ExternalSourceAspects to find |
identifier | string | The identifier of the ExternalSourceAspects to find |
Returns - { aspectId: string, elementId: string }[]
the query results
Defined in
- backend/src/ElementAspect.ts Line 224
Last Updated: 20 June, 2023