step Method
Step this statement to the next row.
For ECSQL SELECT statements the method returns
- DbResult.BE_SQLITE_ROW if the statement now points successfully to the next row.
- DbResult.BE_SQLITE_DONE if the statement has no more rows.
- Error status in case of errors.
For ECSQL INSERT, UPDATE, DELETE statements the method returns
- DbResult.BE_SQLITE_DONE if the statement has been executed successfully.
- Error status in case of errors.
Insert statements can be used with ECDb only, not with IModelDb.
See also: Code Samples
step(): DbResult
Returns - DbResult
Defined in
- backend/src/ECSqlStatement.ts Line 287
Last Updated: 20 June, 2023