bindValues Method
Bind values to all parameters in the statement.
bindValues(values: object | any[]): void
Parameter | Type | Description |
---|---|---|
values | object | any[] | The values to bind to the parameters. Pass an array of values if the parameters are positional. Pass an object of the values keyed on the parameter name for named parameters. The values in either the array or object must match the respective types of the parameter. The section "iTwin.js Types used in ECSQL Parameter Bindings" describes the iTwin.js types to be used for the different ECSQL parameter types. See also these Code Samples |
Returns - void
Defined in
- backend/src/ECSqlStatement.ts Line 238
Last Updated: 20 June, 2023