TreeActions Interface
Tree actions that can be performed on tree.
Methods
Name | Description | |
---|---|---|
onNodeCheckboxClicked(nodeId: string, newState: CheckBoxState): void | ||
onNodeClicked(nodeId: string, event: MouseEvent<Element, MouseEvent>): void | ||
onNodeCollapsed(nodeId: string): void | ||
onNodeEditorActivated(nodeId: string): void | ||
onNodeExpanded(nodeId: string): void | ||
onNodeMouseDown(nodeId: string): void | ||
onNodeMouseMove(nodeId: string): void | ||
onTreeKeyDown(event: KeyboardEvent<Element>): void | ||
onTreeKeyUp(event: KeyboardEvent<Element>): void |
Defined in
Last Updated: 20 June, 2023