Subscribable<T> Interface
Subscribable interface compatible with rxjs This interface ensures that consumers are not required to have rxjs as dependency.
Methods
Name | Description | |
---|---|---|
subscribe(observer?: Observer<T>): Subscription | ||
subscribe(next: undefined | , error: undefined | , complete: () => void): Subscription | ||
subscribe(next: undefined | , error: (error: any) => void, complete?: () => void): Subscription | ||
subscribe(next: (value: T) => void, error: undefined | , complete: () => void): Subscription | ||
subscribe(next?: (value: T) => void, error?: (error: any) => void, complete?: () => void): Subscription |
Defined in
Last Updated: 20 June, 2023