PopupItemProps Interface
Properties of PopupItem component.
Extends
Inherited methods
Name | Inherited from | Description |
---|---|---|
onClick(): void Optional | ToolbarButtonItemProps | Function called when the item is clicked. |
onKeyDown(e: KeyboardEvent<Element>): void Optional | ToolbarButtonItemProps | Function called when a key is pressed. |
Properties
Name | Type | Description | |
---|---|---|---|
hideIndicator | undefined | boolean | Describes if expandable item triangle indicator should be hidden. | |
keepContentsMounted | undefined | boolean | If true the popup panel is mounted once and unmounted when button is unmounted. | |
panel | undefined | ReactNode | Panel of the toolbar. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
addGroupSeparator | undefined | boolean | ToolbarButtonItemProps | If true add a gap before button. |
badge | undefined | ReactNode | ToolbarButtonItemProps | A badge to draw. |
className | undefined | string | ToolbarButtonItemProps | Custom CSS class name |
groupPriority | undefined | number | ToolbarButtonItemProps | value added to DOM element as a data attribute |
icon | undefined | ReactNode | ToolbarButtonItemProps | button icon. |
isActive | undefined | boolean | ToolbarButtonItemProps | Describes if item is active. |
isDisabled | undefined | boolean | ToolbarButtonItemProps | Describes if the item is disabled. |
itemId | undefined | string | ToolbarButtonItemProps | Optional unique identifier for item. |
itemPriority | undefined | number | ToolbarButtonItemProps | value added to DOM element as a data attribute, shows 0 is undefined |
providerId | undefined | string | ToolbarButtonItemProps | value added to DOM element as a data attribute to hold name of items provider. |
style | undefined | CSSProperties | ToolbarButtonItemProps | Custom CSS style properties |
title | string | ToolbarButtonItemProps | Title for the item. |
Defined in
Last Updated: 20 June, 2023