usePropertyData Function
Custom hook that gets PropertyData from given IPropertyDataProvider and subscribes to further data changes.
usePropertyData(props: { dataProvider: IPropertyDataProvider }): { inProgress: boolean, value: undefined | PropertyData }
Parameter | Type | Description |
---|---|---|
props | { dataProvider: IPropertyDataProvider } |
Returns - { inProgress: boolean, value: undefined | PropertyData }
Defined in
Last Updated: 20 June, 2023