PropertyCategoryBlockProps Interface
Properties for the PropertyCategoryBlock React component
Extends
Methods
Name | Description | |
---|---|---|
onExpansionToggled(categoryName: string): void Optional | Callback to when PropertyCategoryBlock gets expended or collapsed |
Properties
Name | Type | Description | |
---|---|---|---|
category | PropertyCategory | Category of the properties | |
highlight | undefined | HighlightingComponentProps | Properties used for highlighting |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | undefined | string | CommonProps | Custom CSS class name |
itemId | undefined | string | CommonProps | Optional unique identifier for item. |
style | undefined | CSSProperties | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 20 June, 2023