FlatGridItemBase Interface
Base immutable data structure defining common methods and properties for categories and categorized properties
Methods
Name | Description | |
---|---|---|
getChildren(): FlatGridItem[] | ||
getDescendantsAndSelf(): FlatGridItem[] | ||
getLastVisibleDescendantOrSelf(): FlatGridItem | ||
getVisibleDescendantsAndSelf(): FlatGridItem[] |
Properties
Name | Type | Description | |
---|---|---|---|
depth Readonly | number | ||
isExpanded Readonly | boolean | ||
isLastInRootCategory Readonly | boolean | ||
key Readonly | string | ||
label Readonly | string | ||
lastInNumberOfCategories Readonly | number | ||
parentCategorySelectionKey Readonly | undefined | string | ||
parentSelectionKey Readonly | undefined | string | ||
selectionKey Readonly | string | ||
type Readonly | FlatGridItemType |
Defined in
Last Updated: 20 June, 2023