FilteredPropertyData Interface
Data returned by FilteringPropertyDataProvider
Extends
Methods
Name | Description | |
---|---|---|
getMatchByIndex(index: number): undefined | HighlightInfo Optional | Function used for getting HighlightInfo by index from all the filtered matches. |
Properties
Name | Type | Description | |
---|---|---|---|
filteredTypes | undefined | FilteredType[] | Types of objects that were used for filtering. | |
matchesCount | undefined | number | Shows how many matches were found when filtering data. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
categories | PropertyCategory[] | PropertyData | |
description | undefined | string | PropertyData | |
label | PropertyRecord | PropertyData | |
records | { T } | PropertyData | |
reusePropertyDataState | undefined | boolean | PropertyData | Should state of existing property data in the component be re-used for this property data |
Defined in
- ui/components-react/src/components-react/propertygrid/dataproviders/FilteringDataProvider.ts Line 29
Last Updated: 20 June, 2023