TableNonPrimitiveValueRendererProps Interface
Properties for TableNonPrimitiveValueRenderer React component
Extends
Inherited methods
Name | Inherited from | Description |
---|---|---|
onDialogOpen(dialogState: PropertyDialogState): void Optional | SharedTableNonPrimitiveValueRendererProps | Callback to request for dialog to be opened. |
Properties
Name | Type | Description | |
---|---|---|---|
buttonLabel | string | Text that will be rendered in the table cell, in other words - Property value | |
dialogContents | ReactNode | Contents of the dialog. | |
dialogTitle | string | Title of the dialog that shows property in more detail. |
Defined in
Last Updated: 20 June, 2023