getFrontstageDef MethodStatic
Find a loaded Frontstage with a given id. If the id is not provided, the active Frontstage is returned. If no cached FrontstageDef is found but a FrontstageProvider is registered a FrontstageDef will be created, cached, and returned.
getFrontstageDef(id?: string): Promise<undefined | FrontstageDef>
Parameter | Type | Description |
---|---|---|
id | string | Id of the Frontstage to find |
Returns - Promise<undefined | FrontstageDef>
FrontstageDef with a given id if found, or undefined if not found.
Defined in
Last Updated: 20 June, 2023