popoutWidget Method
Beta
Create a new popout/child window that contains the widget specified by its Id. Supported only when in UI 2.0 or higher.
popoutWidget(widgetId: string, point?: PointProps, size?: SizeProps): void
Parameter | Type | Description |
---|---|---|
widgetId | string | case sensitive Widget Id |
point | PointProps | Position of top left corner of floating panel in pixels. If undefined {x:0, y:0} is used. |
size | SizeProps | defines the width and height of the floating panel. If undefined and widget has been floated before the previous size is used, else {height:800, width:600} is used. |
Returns - void
Defined in
Last Updated: 20 June, 2023