open Method

Open a new child window.

open(childWindowId: string, title: string, content: ReactNode, location: ChildWindowLocationProps, useDefaultPopoutUrl?: boolean): boolean

Parameter Type Description
childWindowId string Id to assign to the newly created window.
title string Title to display on the window.
content ReactNode ReactNode to be rendered in the window.
location ChildWindowLocationProps Position and size information
useDefaultPopoutUrl boolean use "/iTwinPopup.html" as the window Url, "" otherwise.

Returns - boolean

true if the window is opened successfully.

Last Updated: 20 June, 2023