FooterPopupProps Interface
Beta
Deprecated in 3.5. Props of a deprecated component.
Properties of FooterPopup component.
Extends
- Partial<PopupProps>
Inherited methods
Properties
Name | Type | Description | |
---|---|---|---|
contentType | FooterPopupContentType | Describes content type. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
animate | undefined | boolean | Partial | Indicates whether to use animation for open/close (defaults to true) |
ariaLabel | undefined | string | Partial | accessibility label |
className | undefined | string | Partial | Custom CSS class name |
closeOnContextMenu | undefined | boolean | Partial | Indicates whether to close the popup when the right mouse button is pressed (defaults to true) |
closeOnEnter | undefined | boolean | Partial | Indicates whether to close the popup when Enter is pressed (defaults to true) |
closeOnNestedPopupOutsideClick | undefined | boolean | Partial | If false outside click processing and closing are skipped if click occurs in another Popup component, default to false. |
closeOnWheel | undefined | boolean | Partial | Indicates whether to close the popup when the wheel is used (defaults to true) |
focusTarget | string | RefObject<HTMLElement> | Partial | Element to receive focus, specified by React.RefObject or CSS selector string. |
isOpen | undefined | boolean | Partial | Indicates whether the popup is shown or not (defaults to false) |
isPinned | undefined | boolean | Partial | Indicates whether the popup is pinned. |
itemId | undefined | string | Partial | Optional unique identifier for item. |
keepContentsMounted | undefined | boolean | Partial | If true the children are mounted once and unmounted when this component is unmounted. |
left | undefined | number | Partial | Left position (absolute positioning - defaults to 0) |
moveFocus | undefined | boolean | Partial | set focus to popup - default to not set focus |
offset | undefined | number | Partial | Offset from the parent (defaults to 4) |
position | undefined | RelativePosition | Partial | Direction (relative to the target) to which the popup is expanded (defaults to Bottom) |
repositionOnResize | undefined | boolean | Partial | If true the popup will remain open and will be repositioned when window resize events occur, default to false. |
role | "dialog" | "alert" | "alertdialog" | Partial | Role - if not specified "dialog" is used |
showArrow | undefined | boolean | Partial | Show or hide the arrow (defaults to false) |
showShadow | undefined | boolean | Partial | Show or hide the box shadow (defaults to true) |
style | undefined | CSSProperties | Partial | Custom CSS style properties |
target | | HTMLElement | Partial | Target element to position popup |
top | undefined | number | Partial | Top position (absolute positioning - defaults to 0) |
Defined in
Last Updated: 20 June, 2023