UserProfileProps Interface
Beta
Deprecated in 3.0. Removed from design.
Properties of UserProfile component.
Extends
Methods
Name | Description | |
---|---|---|
onClick(): void Optional | Function called when the profile is clicked. |
Properties
Name | Type | Description | |
---|---|---|---|
children | undefined | string | User name. | |
color | undefined | string | Color of initials circle (CSS value). | |
initials | undefined | string | User initials. | |
safeAreaInsets | undefined | SafeAreaInsets | Describes respected safe area insets. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | undefined | string | CommonProps | Custom CSS class name |
itemId | undefined | string | CommonProps | Optional unique identifier for item. |
style | undefined | CSSProperties | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 20 June, 2023