constructor Method
Constructor for ConditionalStringValue. It is important that the same ConditionalStringValue instance is not used by multiple UI item definitions in order that the control's state is always rendered correctly.
ConditionalStringValue(stringGetter: () => string, syncEventIds: string[], value?: string): ConditionalStringValue
Parameter |
Type |
Description |
stringGetter |
() => string |
Function to run to retrieve the value for the conditional. This function is run when refresh method is called or if the value is not defined in the constructor. |
syncEventIds |
string[] |
An array of eventId that should be monitored to determine when to run the refresh method. |
value |
string |
The default value for the conditional value. If not specified then the function is run to set the value when the value is retrieved. |
Returns - ConditionalStringValue
Defined in
Last Updated:
20 June, 2023