bentleyjs-core
Classes
Name | Description | |
---|---|---|
AbandonedError | Beta | |
BeDuration | A duration of time. | |
BeEvent | Manages a set of listeners for a particular event and notifies them when the event is raised. | |
BeEventList | A list of BeEvent objects, accessible by an event name. | |
BentleyError | The error type thrown by this module. | |
BeTimePoint | A specific point in time relative to the current time. | |
BeUiEvent | Specialization of BeEvent for events that take a single strongly typed argument, primarily used for UI events. | |
ByteStream | Allows the contents of an ArrayBuffer | |
ClientRequestContext | Provides generic context for a server application to get details of a particular | |
Config | Helper class that manages all configuration settings for an iModel.js application. | |
Dictionary | Maintains a mapping of keys to values. | |
DisposableList | A disposable container of disposable objects. | |
Entry | An entry holds the key and value, and pointers to any older and newer entries. | |
IndexedValue | Associates a value of type T with an index representing its insertion order in an IndexMap |
|
IndexMap | Maintains a set of unique elements in sorted order and retains the insertion order of each. | |
Logger | Logger allows libraries and apps to report potentially useful information about operations, and it allows apps and users to control | |
LRUCache | A mapping of a key/value pairs, where the size of the cache can be limited. | |
LRUDictionary | A LRUCache using a Dictionary as its internal storage, permitting custom key comparison logic. | |
LRUMap | A LRUCache using a standard Map as its internal storage. | |
MutableCompressedId64Set | A mutable set of valid Id64Strings sorted in ascending order by the 64-bit unsigned integer value of the Ids. | |
ObservableSet | A standard Set |
|
OneAtATimeAction | Orchestrator of a one-at-a-time activity. | Beta |
OrderedId64Array | A SortedArray of unique Id64Strings sorted in ascending order by the 64-bit unsigned integer values of the Ids. | |
OrderedSet | A mutable ReadonlyOrderedSet. | |
PerfLogger | Simple performance diagnostics utility. | |
PriorityQueue | A priority queue implemented as a heap array. | |
ProcessDetector | Functions to determine the type of JavaScript process currently executing. | |
ReadonlyOrderedSet | A read-only equivalent of Set<T> that maintains its elements in sorted order as specified by a comparison function. |
|
ReadonlySortedArray | A read-only view of an array of some type T sorted according to some user-supplied criterion. | |
SortedArray | Maintains an array of some type T in sorted order. | |
StopWatch | A StopWatch for timing operations. | |
TransientIdSequence | Generates unique Id64String values in sequence, which are guaranteed not to conflict with Ids associated with persistent elements or models. |
Enumerations
Name | Description | |
---|---|---|
AuthStatus | Authentication Errors | Beta |
BentleyLoggerCategory | Logger categories used by this package | |
BentleyStatus | Standard status code. | |
BriefcaseStatus | Error status from various briefcase operations | Beta |
ChangeSetApplyOption | Options that specify how to apply ChangeSets. | |
ChangeSetStatus | Error status from various ChangeSet operations | Beta |
DbOpcode | Values, stored in changesets, that indicate what operation was performed on the database. | |
DbResult | Values for return codes from BeSQLite functions. | |
DuplicatePolicy | Describes how duplicate values are handled when inserting into a SortedArray. | |
ExtensionStatus | iModel.js Extensions | Beta |
GeoServiceStatus | GeoServiceStatus errors | |
HttpStatus | Status from returned HTTP status code | Beta |
IModelHubStatus | iModelHub Services Errors | Beta |
IModelStatus | Status codes that are used in conjunction with BentleyError. | |
LogLevel | Use to categorize logging messages by severity. | |
OpenMode | Whether to open a database readonly or writeable. | |
RepositoryStatus | Return codes for methods which perform repository management operations | Beta |
RpcInterfaceStatus | RpcInterface status codes | Beta |
WSStatus | Server returned WSG errors | Beta |
Global Functions
Name | Description | |
---|---|---|
areEqualPossiblyUndefined | Compare two possibly-undefined values for equality. | |
asInstanceOf | Cast obj to an instance of class T , or return undefined if obj is not an instance of class T . |
|
assert | Asserts that a condition is true , and in development builds throws an error if it is not. |
|
base64StringToUint8Array | Given a base-64-encoded string, decode it into an array of bytes. | |
compareBooleans | ||
compareBooleansOrUndefined | ||
compareNumbers | ||
compareNumbersOrUndefined | ||
comparePossiblyUndefined | ||
compareStrings | ||
compareStringsOrUndefined | ||
compareWithTolerance | An OrderedComparator for numbers that treats two numbers as equal if the absolute value of their difference is less than a specified tolerance. | |
dispose | Convenience function for disposing of a disposable object that may be undefined. | |
disposeArray | Disposes of and empties a list of disposable objects. | |
isIDisposable | A type guard that checks whether the given argument implements IDisposable interface |
|
isInstanceOf | Returns true if obj is an object of class T . |
|
lowerBound | Given a sorted array, computes the position at which the specified value should be inserted into the array so that the array remains sorted. | |
partitionArray | Partitions an array in-place according to some criterion, such that elements that fulfill the criterion are grouped in the lower | |
shallowClone | A CloneFunction that, given a value of type T, returns the same value. | |
using | A 'using' function which is a substitution for .NET's using statement. | |
utf8ToString | Given an array of bytes containing a utf-8 string, convert to a string. |
Interfaces
Name | Description | |
---|---|---|
ClientRequestContextProps | The properties of ClientRequestContext. | |
DictionaryEntry | Represents an entry in a Dictionary. | |
EntryContainer | The interface that must be satisfied by the underlying container type used by a LRUCache. | |
IDisposable | Interface adopted by a type which has deterministic cleanup logic. | |
LoggerCategoryAndLevel | Identifies a logging category and the LogLevel that should be used for it. | |
LoggerLevelsConfig | Specifies logging levels, including the default logging level and a set of categories and levels for them. | |
SerializedClientRequestContext | Serialized format for sending the client request context across the RPC layer | |
SessionProps | Properties that identify a session. | |
When you want to associate an explanatory message with an error status value. | Beta |
Namespaces
Name | Description | |
---|---|---|
CompressedId64Set | A compact string representation of an Id64Set. | |
Guid | The Guid namespace provides facilities for working with GUID strings using the "8-4-4-4-12" pattern. | |
Id64 | The Id64 namespace provides facilities for working with 64-bit identifiers. | |
JsonUtils | Utility functions for converting from JSON objects, with default values. | |
OrderedId64Iterable | A collection of valid Id64Strings sorted in ascending order by the unsigned 64-bit integer value of the Ids. |
Type Aliases
Name | Description | |
---|---|---|
CloneFunction | ||
CompressedId64Set | ||
ComputePriorityFunction | ||
Constructor | ||
DisposeFunc | ||
GetMetaDataFunction | ||
GuidString | A string containing a well-formed string representation of a Guid. | |
Id64Arg | Used as an argument to a function that can accept one or more Id64Strings. | |
Id64Array | An array of Id64Strings. | |
Id64Set | A set of Id64Strings. | |
Id64String | A string containing a well-formed string representation of an Id64. | |
Listener | ||
LogFunction | ||
Mutable | The inverse of TypeScript's ReadonlyT with any readonly modifiers removed. |
|
OrderedComparator | ||
OrderedId64Iterable |
Last Updated: 11 June, 2024