Ids
Classes for working with unique identifiers.
Classes
Name | Description | |
---|---|---|
TransientIdSequence | Generates unique Id64String values in sequence, which are guaranteed not to conflict with Ids associated with persistent elements or models. |
Namespaces
Name | Description | |
---|---|---|
Guid | The Guid namespace provides facilities for working with GUID strings using the "8-4-4-4-12" pattern. | |
Id64 | The Id64 namespace provides facilities for working with 64-bit identifiers. |
Type Aliases
Name | Description | |
---|---|---|
GuidString | A string containing a well-formed string representation of a Guid. | |
Id64Arg | Used as an argument to a function that can accept one or more Id64Strings. | |
Id64Array | An array of Id64Strings. | |
Id64Set | A set of Id64Strings. | |
Id64String | A string containing a well-formed string representation of an Id64. |
Last Updated: 13 June, 2024