GlobeAnimator Class

Animates the transition of a Viewport to view a location on the Earth. The animation traces a flight path from the viewport's current Frustum to the destination. The duration of the animation varies based on the distance traversed.

@see animateFlyoverToGlobalLocation.

Implements

Methods

Name Description
constructor(viewport: ScreenViewport, destination: GlobalLocation, afterLanding: Frustum, afterFocus: number): GlobeAnimator Protected    
_moveFixToFraction(fract: number, interpolator: SmoothTransformBetweenFrusta): boolean Protected Apply a SmoothTransformBetweenFrusta interpolator to the view based on a fraction.  
_moveFlightToFraction(fraction: number): boolean Protected    
create(viewport: ScreenViewport, destination: GlobalLocation): Promise<undefined | GlobeAnimator> Static Create an animator to transition to the specified destination.  

Properties

Name Type Description
_afterFocusDistance Protected number    
_afterLanding Protected Frustum    
_columbusLine Protected Point3d[]    
_ellipsoidArc Protected Arc3d | undefined    
_endHeight Protected number | undefined    
_endLocation Protected GlobalLocation    
_fixLandingFraction Protected Readonly number    
_fixLandingInterpolator Protected SmoothTransformBetweenFrusta | undefined    
_fixTakeoffFraction Protected number | undefined    
_fixTakeoffInterpolator Protected SmoothTransformBetweenFrusta | undefined    
_flightLength Protected number    
_flightTweens Protected Tweens    
_midHeight Protected number | undefined    
_scratchFrustum Protected Readonly Frustum    
_startCartographic Protected Cartographic | undefined    
_startHeight Protected number | undefined    
_viewport Protected ScreenViewport    

Defined in

Last Updated: 13 May, 2024