createStyle MethodStatic
Insert a new line style with the supplied name.
createStyle(imodel: IModelDb, scopeModelId: string, name: string, props: LineStyleDefinition.StyleProps): string
@throws IModelError if unable to insert the line style definition element.
Parameter | Type | Description |
---|---|---|
imodel | IModelDb | |
scopeModelId | string | |
name | string | |
props | LineStyleDefinition.StyleProps |
Returns - string
Defined in
- core/backend/src/LineStyle.ts Line 374
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.