createPointSymbolComponent MethodStatic
Create a file property for a new point symbol component. If base and size parameters are not supplied, queries GeometryPart by id to set them.
createPointSymbolComponent(iModel: IModelDb, props: LineStyleDefinition.PointSymbolProps): undefined | LineStyleDefinition.StyleProps
Parameter | Type | Description |
---|---|---|
iModel | IModelDb | |
props | LineStyleDefinition.PointSymbolProps |
Returns - undefined | LineStyleDefinition.StyleProps
Defined in
- core/backend/src/LineStyle.ts Line 316
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.