ElementProperties Interface

Data structure for storing element properties information in a simplified format.

@see Content for a format that stores all available element property data.

Properties

Name Type Description
class string Label of element's ECClass.  
id string Element's ID.  
items [label: string]: ElementPropertiesItem Container of property values  
label string Element's label.  

Defined in

Last Updated: 13 May, 2024