OffsetMeshSelectiveOutputOptions Interface

Selective output options for PolyfaceQuery.cloneOffset:

  • undefined means the usual facets in the expected offset mesh.
  • if present as a json object, the various booleans select respective outputs.

Properties

Name Type Description
outputOffsetsFromEdges boolean | undefined    
outputOffsetsFromFaces boolean | undefined    
outputOffsetsFromFacesBeforeChamfers boolean | undefined    
outputOffsetsFromVertices boolean | undefined    

Defined in

Last Updated: 13 May, 2024