ToolTipProvider Interface

An object that can contribute customizations to the tooltip displayed when mousing over an element or other entity in a Viewport.

@see addToolTipProvider to register a tooltip provider.

Methods

Name Description
augmentToolTip(hit: HitDetail, tooltip: Promise<string | HTMLElement>): Promise<string | HTMLElement> Augment or replace the tooltip for the specified HitDetail.  

Defined in

Last Updated: 13 May, 2024