BeWheelEventProps Interface

Properties for constructing a BeWheelEvent

Extends

Implemented by

Properties

Name Type Description
time number | undefined    
wheelDelta number | undefined    

Inherited properties

Name Type Inherited from Description
button BeButton | undefined BeButtonEventProps The mouse button for this event.
coordsFrom CoordSource | undefined BeButtonEventProps How the coordinate values were generated (either from an action by the user or from a program.)
inputSource InputSource | undefined BeButtonEventProps Whether this event came from a pointing device (e.g.
isDoubleClick boolean | undefined BeButtonEventProps If true, this is the second down in a rapid double-click of the same button.
isDown boolean | undefined BeButtonEventProps If true, this event was generated from a mouse-down transition, false from a button-up transition.
isDragging boolean | undefined BeButtonEventProps If true, this event was created by pressing, holding, and then moving a mouse button.
keyModifiers BeModifierKeys | undefined BeButtonEventProps  
point Point3d | undefined BeButtonEventProps The point for this event, in world coordinates.
rawPoint Point3d | undefined BeButtonEventProps The raw (unadjusted) point for this event, in world coordinates.
viewPoint Point3d | undefined BeButtonEventProps The point, in screen coordinates for this event.
viewport ScreenViewport | undefined BeButtonEventProps The ScreenViewport for the BeButtonEvent.

Defined in

Last Updated: 13 May, 2024